понедельник, 11 марта 2019 г.

Обновление certbot до 13 марта 2019 (lets encrypt)

Сегодня мне пришло письмо с таким содержанием

Your Let's Encrypt client used ACME TLS-SNI-01 domain validation to issue a

certificate in the past 7 days. Below is a list of names and IP addresses

validated (max of one per account):





TLS-SNI-01 validation is reaching end-of-life. It will stop working

permanently on March 13th, 2019. Any certificates issued before then will

continue to work for 90 days after their issuance date.



You need to update your ACME client to use an alternative validation method

(HTTP-01, DNS-01 or TLS-ALPN-01) before this date or your certificate renewals

will break and existing certificates will start to expire.


Оказалось что у меня certbot в Debian 9 стоял аж версии 0.10, а последняя актуальная 0.28

Узнать версию можно командой

certbot --version




Если версия 0.28 или выше, то всё будет в норме, если же ниже, то с 13 марта ваши сертификаты перестанут обновляться старым certbot...


Для 9го Дебиана надо подключить репозиторий backports, для этого в /etc/apt/sources.list добавить строчку:

deb http://mirror.yandex.ru/debian/ stretch-backports main contrib non-free

 а дальше ввести команду от рута или через судо:

apt-get install certbot python-certbot-nginx -t stretch-backports

А потом для полного обновления

sudo certbot renew --dry-run 




Комментариев нет:

Отправить комментарий